Apps antigos podem ter funcionamento bloqueado no Android P

Por Eduardo Hayashi | 19 de Março de 2018 às 11h13
Tudo sobre

Google

Além dos novos recursos e aprimoramentos de performance esperados no Android P, parece que a atualização do sistema operacional móvel também estabelecerá requisitos mínimos para que os aplicativos funcionem.

Isso porque desenvolvedores analisaram a versão prévia do Android P e descobriram que ele vai exigir o uso de APIs mais recentes nos aplicativos. Caso o aplicativo não possua a versão 17 ou superior da interface de programação, o sistema retornará com a mensagem de erro "Este aplicativo foi criado para uma versão mais antiga do Android e pode não funcionar corretamente. Tente verificar atualizações ou entre em contato com o desenvolvedor".

A Google já havia dado os primeiros passos para reduzir a quantidade de aplicativos obsoletos na Play Store. Com essa nova mudança, é provável que os apps desatualizados sejam descartados quase que completamente do sistema operacional.

Participe do nosso GRUPO CANALTECH DE DESCONTOS do Whatsapp e do Facebook e garanta sempre o menor preço em suas compras de produtos de tecnologia.

Vale notar que o requisito foi encontrado na versão prévia, e ele pode tanto ser implementado quanto descartado até que versão final do Android P chegue a todos os usuários. 

Fonte: GSMArena

Gostou dessa matéria?

Inscreva seu email no Canaltech para receber atualizações diárias com as últimas notícias do mundo da tecnologia.