Apple exigirá suporte a 64 bits em aplicativos iOS a partir de fevereiro

Por Redação | 21.10.2014 às 10:44
photo_camera Divulgação

Em um anúncio feito no seu portal Web Developer nesta segunda-feira (20), a Apple informou para os desenvolvedores de iPhone e iPad que as soluções feitas por eles deverão obrigatoriamente incluir suporte a 64 bits e ser construídos usando o iOS SDK 8. Tal requisição da Maçã começará a valer no dia 1º de fevereiro de 2015.

O anúncio postado na página da Apple não é nenhuma surpresa para aqueles que já acompanham os passos da empresa. Os atuais chips da empresa, o A7 e o A8, já apresentam suporte a aplicações 64 bits e, portanto é natural que a empresa tome uma medida como essa. Abaixo você confere um trecho do comunicado emitido pela Apple.

"Começando no dia 1º de fevereiro de 2015, os novos aplicativos para iOS enviados para a Apple Store devem incluir suporte a 64 bits e serem construídos com o iOS SDK 8, incluídos no Xcode 6 ou superior. Para habilitar o 64 bits em um projeto, recomendamos utilizar uma definição de compilação Xcode de 'arquitetura padrão' para construir um único binário com ambos os suportes a 32 bits e 64 bits."

A primeira vez que a Apple trouxe a computação de 64 bits em aparelhos móveis foi no lançamento do iPhone 5S em 2013. Desde então, tem expandido o avanço aos processadores dos iPads. Com a introdução dessa tecnologia nos novos iPhones (6 e 6 Plus), o único iPhone disponível para venda que não suporta a arquitetura 64 bits é o modelo 5C.

A introdução do 64 bits em smartphones e tablets supostamente "desencadeou pânico" nos fabricantes de chips rivais como a Qualcomm, que não tinha roteiros tão agressivos em relação a tecnologia. Na época, as concorrentes da Apple questionaram a tecnologia alegando que era desnecessária para tarefas de computação portátil. Mas este conceito mudou rapidamente, visto que diversas fabricantes já estão investindo no desenvolvimento de seus próprios produtos 64 bits.

Os desenvolvedores podem realizar o download da última versão do Xcode, a 6.1 com dados do iOS SDK 8, através do Developer Center da Apple.

Fonte: http://iphone.appleinsider.com/articles/14/10/20/apple-to-require-64-bit-support-from-all-ios-apps-starting-in-february