Apple corrigiu grave falha no OS X, mas apenas para usuários do Yosemite

Por Redação | 10 de Abril de 2015 às 17h49
photo_camera Apple Computer Inc.

Uma grave vulnerabilidade presente em desktops da Apple com OS X a partir da versão 10.7 foi divulgada ao público nesta quinta-feira (9). A Maçã aconselha que todos os usuários atualizem as versões mais antigas do OS X para a versão mais recente do Yosemite, ou então continuarão vulneráveis.

A falha em questão permite a qualquer usuário do OS X, com ou sem direitos administrativos, acesso root ao sistema por meio da exploração de uma API não publicada. Na verdade, esse bug foi descoberto por um pesquisador de segurança em outubro do ano passado e relatado imediatamente à Apple, mas a companhia pediu que ele adiasse a divulgação pública – o que geralmente é feito por 90 dias – "devido à quantidade de alterações necessárias no OS X". Porém, a correção só saiu esta semana.

A Apple está aconselhando fortemente seus usuários a atualizarem o sistema, pois as versões anteriores à 10.10 não serão corrigidas devido à complexidade do procedimento.

A versão final do OS X 10.10.3 foi liberada na última quarta-feira (08) e, além de melhorias básicas, trouxe também novidades como o aplicativo de fotos que vem para substituir o iPhoto e o Mac Aperture.

Via Engadget

Siga o Canaltech no Twitter!

Não perca nenhuma novidade do mundo da tecnologia.